Vulnerability Name:

CVE-2008-1602

Assigned:2008-04-03
Published:2008-04-03
Updated:2017-08-07
Summary:Stack-based buffer overflow in Orbit downloader 2.6.3 and 2.6.4 allows remote attackers to execute arbitrary code via a long download URL, which is not properly handled during Unicode conversion for a balloon notification after a download has failed.
CVSS v3 Severity:7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:10.0 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C)
8.3 High (Temporal CVSS v2 Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C/E:F/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
6.8 Medium (CCN CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P)
5.6 Medium (CCN Temporal CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P/E:F/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-119
References:Source: SREASON
Type: UNKNOWN
3798

Source: MISC
Type: PATCH
http://www.coresecurity.com/?action=item&id=2211

Source: BUGTRAQ
Type: PATCH
20080403 CORE-2008-0314 - Orbit Downloader "Download failed" buffer overflow

Source: BID
Type: PATCH
28541

Source: VUPEN
Type: UNKNOWN
ADV-2008-1101

Source: XF
Type: UNKNOWN
orbitdownloader-url-bo(41649)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:orbit_downloader:orbit_downloader:2.6.3:*:*:*:*:*:*:*
  • OR cpe:/a:orbit_downloader:orbit_downloader:2.6.4:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:orbit_downloader:orbit_downloader:2.6.3:*:*:*:*:*:*:*
  • OR cpe:/a:orbit_downloader:orbit_downloader:2.6.4:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    orbit_downloader orbit downloader 2.6.3
    orbit_downloader orbit downloader 2.6.4
    orbit_downloader orbit downloader 2.6.3
    orbit_downloader orbit downloader 2.6.4