Vulnerability Name:

CVE-2013-4122

Assigned:2013-06-12
Published:2013-10-26
Updated:2016-12-07
Summary:Cyrus SASL 2.1.23, 2.1.26, and earlier does not properly handle when a NULL value is returned upon an error by the crypt function as implemented in glibc 2.17 and later, which allows remote attackers to cause a denial of service (thread crash and consumption) via (1) an invalid salt or, when FIPS-140 is enabled, a (2) DES or (3) MD5 encrypted password, which triggers a NULL pointer dereference.
CVSS v3 Severity:3.7 Low (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P)
3.2 Low (Temporal CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P)
3.7 Low (CCN Temporal CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
Vulnerability Type:CWE-189
References:Source: CONFIRM
Type: PATCH
http://git.cyrusimap.org/cyrus-sasl/commit/?id=dedad73e5e7a75d01a5f3d5a6702ab8ccd2ff40d

Source: GENTOO
Type: UNKNOWN
GLSA-201309-01

Source: DEBIAN
Type: UNKNOWN
DSA-3368

Source: MLIST
Type: UNKNOWN
[oss-security] 20130712 CVE request: Cyrus-sasl NULL ptr. dereference

Source: MLIST
Type: UNKNOWN
[oss-security] 20130712 Re: CVE request: Cyrus-sasl NULL ptr. dereference

Source: MLIST
Type: UNKNOWN
[oss-security] 20130713 Re: CVE request: Cyrus-sasl NULL ptr. dereference

Source: MLIST
Type: UNKNOWN
[oss-security] 20130715 Re: CVE request: Cyrus-sasl NULL ptr. dereference

Source: UBUNTU
Type: UNKNOWN
USN-2755-1

Source: XF
Type: UNKNOWN
cyrus-cve20134122-dos(85628)

Source: MISC
Type: UNKNOWN
https://www.linuxquestions.org/questions/slackware-14/%5Bslackware-current%5D-glibc-2-17-shadow-and-other-penumbrae-4175461061/

Vulnerable Configuration:Configuration 1:
  • cpe:/a:cmu:cyrus-sasl:2.1.24:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.25:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.26:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.23:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.22:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.21:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.20:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:2.1.19:*:*:*:*:*:*:*
  • OR cpe:/a:cmu:cyrus-sasl:1.5.28:*:*:*:*:*:*:*
  • AND
  • cpe:/a:gnu:glibc:2.17:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.18:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2.1:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2.2:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2.3:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2.4:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.2.5:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.1:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.10:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.2:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.3:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.4:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.5:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.3.6:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.4:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.5:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.5.1:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.6:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.6.1:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.7:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.8:*:*:*:*:*:*:*
  • OR cpe:/a:gnu:glibc:2.9:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.cisecurity:def:166
    P
    DSA-3368-1 -- cyrus-sasl2 -- security update
    2016-02-08
    oval:org.mitre.oval:def:19157
    P
    USN-1988-1 -- cyrus-sasl2 vulnerability
    2014-06-30
    oval:com.ubuntu.precise:def:20134122000
    V
    CVE-2013-4122 on Ubuntu 12.04 LTS (precise) - medium.
    2013-10-26
    oval:com.ubuntu.trusty:def:20134122000
    V
    CVE-2013-4122 on Ubuntu 14.04 LTS (trusty) - medium.
    2013-10-26
    BACK
    cmu cyrus-sasl 2.1.24
    cmu cyrus-sasl 2.1.25
    cmu cyrus-sasl 2.1.26
    cmu cyrus-sasl 2.1.23
    cmu cyrus-sasl 2.1.22
    cmu cyrus-sasl 2.1.21
    cmu cyrus-sasl 2.1.20
    cmu cyrus-sasl 2.1.19
    cmu cyrus-sasl 1.5.28
    gnu glibc 2.17
    gnu glibc 2.18
    gnu glibc 2.2
    gnu glibc 2.2.1
    gnu glibc 2.2.2
    gnu glibc 2.2.3
    gnu glibc 2.2.4
    gnu glibc 2.2.5
    gnu glibc 2.3
    gnu glibc 2.3.1
    gnu glibc 2.3.10
    gnu glibc 2.3.2
    gnu glibc 2.3.3
    gnu glibc 2.3.4
    gnu glibc 2.3.5
    gnu glibc 2.3.6
    gnu glibc 2.4
    gnu glibc 2.5
    gnu glibc 2.5.1
    gnu glibc 2.6
    gnu glibc 2.6.1
    gnu glibc 2.7
    gnu glibc 2.8
    gnu glibc 2.9