Vulnerability Name:

CVE-2013-4965

Assigned:2013-07-29
Published:2013-10-25
Updated:2013-10-28
Summary:Puppet Enterprise before 3.1.0 does not properly restrict the number of authentication attempts by a console account, which makes it easier for remote attackers to bypass intended access restrictions via a brute-force attack.
CVSS v3 Severity:5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N)
3.7 Low (Temporal CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N)
3.7 Low (CCN Temporal CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-287
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://puppetlabs.com/security/cve/cve-2013-4965

Source: XF
Type: UNKNOWN
puppet-cve20134965-sec-bypass(88577)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:puppetlabs:puppet:3.0.1:-:enterprise:*:*:*:*:*
  • OR cpe:/a:puppetlabs:puppet:3.0.0:-:enterprise:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.precise:def:20134965000
    V
    CVE-2013-4965 on Ubuntu 12.04 LTS (precise) - medium.
    2013-10-25
    BACK
    puppetlabs puppet 3.0.1 -
    puppetlabs puppet 3.0.0 -