Vulnerability Name:

CVE-2014-1591

Assigned:2014-01-16
Published:2014-12-11
Updated:2016-12-21
Summary:Mozilla Firefox 33.0 and SeaMonkey before 2.31 include path strings in CSP violation reports, which allows remote attackers to obtain sensitive information via a web site that receives a report after a redirect.
CVSS v3 Severity:3.7 Low (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
Vulnerability Type:CWE-199
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://www.mozilla.org/security/announce/2014/mfsa2014-86.html

Source: CONFIRM
Type: UNKNOWN
http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html

Source: CONFIRM
Type: UNKNOWN
https://bugzilla.mozilla.org/show_bug.cgi?id=1069762

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201504-01

Vulnerable Configuration:Configuration 1:
  • cpe:/a:mozilla:seamonkey:2.30:*:*:*:*:*:*:*
  • OR cpe:/a:mozilla:firefox:33.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20141591
    V
    CVE-2014-1591
    2017-09-24
    oval:org.mitre.oval:def:28351
    P
    USN-2424-1 -- Firefox vulnerabilities
    2015-03-09
    oval:org.mitre.oval:def:27870
    P
    SUSE-SU-2014:1624-1 -- Security update for Mozilla Firefox (important)
    2015-02-23
    oval:com.ubuntu.precise:def:20141591000
    V
    CVE-2014-1591 on Ubuntu 12.04 LTS (precise) - medium.
    2014-12-11
    oval:com.ubuntu.trusty:def:20141591000
    V
    CVE-2014-1591 on Ubuntu 14.04 LTS (trusty) - medium.
    2014-12-11
    BACK
    mozilla seamonkey 2.30
    mozilla firefox 33.0