Vulnerability Name:

CVE-2014-3775

Assigned:2014-05-19
Published:2014-05-22
Updated:2016-12-21
Summary:libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.
CVSS v3 Severity:7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:7.5 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-20
References:Source: MLIST
Type: UNKNOWN
http://lists.ziew.org/pipermail/libgadu-devel/2014-May/001171.html

Source: MLIST
Type: UNKNOWN
http://lists.ziew.org/pipermail/libgadu-devel/2014-May/001180.html

Source: DEBIAN
Type: UNKNOWN
http://www.debian.org/security/2014/dsa-2935

Source: MLIST
Type: UNKNOWN
http://www.openwall.com/lists/oss-security/2014/05/19/3

Source: BID
Type: UNKNOWN
67471

Source: UBUNTU
Type: UNKNOWN
http://www.ubuntu.com/usn/USN-2215-1

Source: UBUNTU
Type: UNKNOWN
http://www.ubuntu.com/usn/USN-2216-1

Source: CONFIRM
Type: UNKNOWN
https://bugzilla.redhat.com/show_bug.cgi?id=1099776

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201508-02

Vulnerable Configuration:Configuration 1:
  • cpe:/a:libgadu:libgadu:1.12.0:rc3:*:*:*:*:*:*
  • OR cpe:/a:libgadu:libgadu:1.12.0:rc2:*:*:*:*:*:*
  • OR cpe:/a:libgadu:libgadu:1.12.0:rc1:*:*:*:*:*:*
  • OR cpe:/a:libgadu:libgadu:1.11.4:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20143775
    V
    CVE-2014-3775
    2017-09-24
    oval:org.mitre.oval:def:24375
    P
    USN-2215-1 -- libgadu vulnerability
    2014-07-21
    oval:org.mitre.oval:def:24796
    P
    DSA-2935-1 libgadu - security update
    2014-07-21
    oval:org.mitre.oval:def:24012
    P
    USN-2216-1 -- pidgin vulnerability
    2014-07-21
    oval:com.ubuntu.precise:def:20143775000
    V
    CVE-2014-3775 on Ubuntu 12.04 LTS (precise) - medium.
    2014-05-22
    oval:com.ubuntu.trusty:def:20143775000
    V
    CVE-2014-3775 on Ubuntu 14.04 LTS (trusty) - medium.
    2014-05-22
    oval:com.ubuntu.xenial:def:20143775000
    V
    CVE-2014-3775 on Ubuntu 16.04 LTS (xenial) - medium.
    2014-05-22
    BACK
    libgadu libgadu 1.12.0 rc3
    libgadu libgadu 1.12.0 rc2
    libgadu libgadu 1.12.0 rc1
    libgadu libgadu 1.11.4