Vulnerability Name:

CVE-2014-4002

Assigned:2014-06-09
Published:2014-07-03
Updated:2016-12-21
Summary:Multiple cross-site scripting (XSS) vulnerabilities in Cacti 0.8.8b allow remote attackers to inject arbitrary web script or HTML via the (1) drp_action parameter to cdef.php, (2) data_input.php, (3) data_queries.php, (4) data_sources.php, (5) data_templates.php, (6) graph_templates.php, (7) graphs.php, (8) host.php, or (9) host_templates.php or the (10) graph_template_input_id or (11) graph_template_id parameter to graph_templates_inputs.php.
CVSS v3 Severity:3.7 Low (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-79
References:Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-updates/2015-03/msg00034.html

Source: CONFIRM
Type: PATCH
http://svn.cacti.net/viewvc?view=rev&revision=7451

Source: CONFIRM
Type: PATCH
http://svn.cacti.net/viewvc?view=rev&revision=7452

Source: DEBIAN
Type: UNKNOWN
http://www.debian.org/security/2014/dsa-2970

Source: BID
Type: UNKNOWN
68257

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201509-03

Vulnerable Configuration:Configuration 1:
  • cpe:/o:novell:opensuse:13.1:*:*:*:*:*:*:*
  • OR cpe:/o:novell:opensuse:13.2:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:cacti:cacti:0.8.8b:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20144002
    V
    CVE-2014-4002
    2017-03-20
    oval:org.mitre.oval:def:25061
    P
    DSA-2970-1 cacti - security update
    2014-08-11
    oval:com.ubuntu.precise:def:20144002000
    V
    CVE-2014-4002 on Ubuntu 12.04 LTS (precise) - medium.
    2014-07-03
    oval:com.ubuntu.trusty:def:20144002000
    V
    CVE-2014-4002 on Ubuntu 14.04 LTS (trusty) - medium.
    2014-07-03
    oval:com.ubuntu.xenial:def:20144002000
    V
    CVE-2014-4002 on Ubuntu 16.04 LTS (xenial) - medium.
    2014-07-03
    BACK
    novell opensuse 13.1
    novell opensuse 13.2
    cacti cacti 0.8.8b