Vulnerability Name:

CVE-2014-4986

Assigned:2014-07-16
Published:2014-07-20
Updated:2016-12-21
Summary:Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.
CVSS v3 Severity:2.6 Low (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:3.5 Low (CVSS v2 Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-79
References:Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-updates/2014-08/msg00045.html

Source: CONFIRM
Type: VENDOR_ADVISORY
http://www.phpmyadmin.net/home_page/security/PMASA-2014-6.php

Source: BID
Type: UNKNOWN
68803

Source: CONFIRM
Type: UNKNOWN
https://github.com/phpmyadmin/phpmyadmin/commit/29a1f56495a7d1d98da31a614f23c0819a606a4d

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201505-03

Vulnerable Configuration:Configuration 1:
  • cpe:/a:phpmyadmin:phpmyadmin:4.2.4:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.2.3:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.2.2:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.2.1:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.2.0:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.9:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.8:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.7:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.6:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.5:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.4:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.3:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.2:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.14.1:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.14:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.13:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.12:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.11:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.10:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.1:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.1.0:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.9:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.8:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.7:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.6:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.5:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.4.2:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.4.1:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.4:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.3:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.10:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.0:rc3:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.0:rc2:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.2.5:*:*:*:*:*:*:*
  • OR cpe:/a:phpmyadmin:phpmyadmin:4.0.10.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20144986
    V
    CVE-2014-4986
    2017-03-01
    oval:com.ubuntu.precise:def:20144986000
    V
    CVE-2014-4986 on Ubuntu 12.04 LTS (precise) - medium.
    2014-07-20
    oval:com.ubuntu.trusty:def:20144986000
    V
    CVE-2014-4986 on Ubuntu 14.04 LTS (trusty) - medium.
    2014-07-20
    oval:com.ubuntu.xenial:def:20144986000
    V
    CVE-2014-4986 on Ubuntu 16.04 LTS (xenial) - medium.
    2014-07-20
    BACK
    phpmyadmin phpmyadmin 4.2.4
    phpmyadmin phpmyadmin 4.2.3
    phpmyadmin phpmyadmin 4.2.2
    phpmyadmin phpmyadmin 4.2.1
    phpmyadmin phpmyadmin 4.2.0
    phpmyadmin phpmyadmin 4.1.9
    phpmyadmin phpmyadmin 4.1.8
    phpmyadmin phpmyadmin 4.1.7
    phpmyadmin phpmyadmin 4.1.6
    phpmyadmin phpmyadmin 4.1.5
    phpmyadmin phpmyadmin 4.1.4
    phpmyadmin phpmyadmin 4.1.3
    phpmyadmin phpmyadmin 4.1.2
    phpmyadmin phpmyadmin 4.1.14.1
    phpmyadmin phpmyadmin 4.1.14
    phpmyadmin phpmyadmin 4.1.13
    phpmyadmin phpmyadmin 4.1.12
    phpmyadmin phpmyadmin 4.1.11
    phpmyadmin phpmyadmin 4.1.10
    phpmyadmin phpmyadmin 4.1.1
    phpmyadmin phpmyadmin 4.1.0
    phpmyadmin phpmyadmin 4.0.9
    phpmyadmin phpmyadmin 4.0.8
    phpmyadmin phpmyadmin 4.0.7
    phpmyadmin phpmyadmin 4.0.6
    phpmyadmin phpmyadmin 4.0.5
    phpmyadmin phpmyadmin 4.0.4.2
    phpmyadmin phpmyadmin 4.0.4.1
    phpmyadmin phpmyadmin 4.0.4
    phpmyadmin phpmyadmin 4.0.3
    phpmyadmin phpmyadmin 4.0.2
    phpmyadmin phpmyadmin 4.0.10
    phpmyadmin phpmyadmin 4.0.1
    phpmyadmin phpmyadmin 4.0.0 rc3
    phpmyadmin phpmyadmin 4.0.0 rc2
    phpmyadmin phpmyadmin 4.0.0
    phpmyadmin phpmyadmin 4.2.5
    phpmyadmin phpmyadmin 4.0.10.0