Vulnerability Name:

CVE-2014-6587

Assigned:2014-09-17
Published:2015-01-20
Updated:2016-12-21
Summary:Unspecified vulnerability in Oracle Java SE 6u85, 7u72, and 8u25 allows local users to affect confidentiality, integrity, and availability via unknown vectors related to Libraries.
CVSS v3 Severity:4.8 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:L/AC:L/Au:S/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
4.1 Medium (REDHAT CVSS v2 Vector: AV:L/AC:M/Au:S/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-476
References:Source: HP
Type: UNKNOWN
http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04583581

Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00001.html

Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00024.html

Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00018.html

Source: HP
Type: UNKNOWN
http://marc.info/?l=bugtraq&m=142496355704097&w=2

Source: HP
Type: UNKNOWN
http://marc.info/?l=bugtraq&m=142607790919348&w=2

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0068.html

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0079.html

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0080.html

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0085.html

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0086.html

Source: REDHAT
Type: UNKNOWN
http://rhn.redhat.com/errata/RHSA-2015-0264.html

Source: DEBIAN
Type: UNKNOWN
http://www.debian.org/security/2015/dsa-3144

Source: DEBIAN
Type: UNKNOWN
http://www.debian.org/security/2015/dsa-3147

Source: CONFIRM
Type: VENDOR_ADVISORY
http://www.oracle.com/technetwork/topics/security/cpujan2015-1972971.html

Source: BID
Type: UNKNOWN
72168

Source: SECTRACK
Type: UNKNOWN
1031580

Source: UBUNTU
Type: UNKNOWN
http://www.ubuntu.com/usn/USN-2486-1

Source: UBUNTU
Type: UNKNOWN
http://www.ubuntu.com/usn/USN-2487-1

Source: CONFIRM
Type: UNKNOWN
http://www.vmware.com/security/advisories/VMSA-2015-0003.html

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201507-14

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201603-14

Source: CONFIRM
Type: UNKNOWN
https://www-304.ibm.com/support/docview.wss?uid=swg21695474

Vulnerable Configuration:Configuration 1:
  • cpe:/a:oracle:jdk:1.6.0:update_85:*:*:*:*:*:*
  • OR cpe:/a:oracle:jre:1.6.0:update_85:*:*:*:*:*:*
  • OR cpe:/a:oracle:jre:1.7.0:update_72:*:*:*:*:*:*
  • OR cpe:/a:oracle:jdk:1.7.0:update_72:*:*:*:*:*:*
  • OR cpe:/a:oracle:jre:1.8.0:update_25:*:*:*:*:*:*
  • OR cpe:/a:oracle:jdk:1.8.0:update_25:*:*:*:*:*:*

  • Configuration RedHat 1:
  • cpe:/o:redhat:enterprise_linux:7:*:*:*:*:*:*:*

  • Configuration RedHat 2:
  • cpe:/o:redhat:enterprise_linux:6:*:*:*:*:*:*:*

  • Configuration RedHat 3:
  • cpe:/o:redhat:enterprise_linux:5:*:*:*:*:*:*:*

  • Configuration RedHat 4:
  • cpe:/a:redhat:rhel_extras_oracle_java:6:*:*:*:*:*:*:*

  • Configuration RedHat 5:
  • cpe:/a:redhat:rhel_extras_oracle_java:5:*:*:*:*:*:*:*

  • Configuration RedHat 6:
  • cpe:/a:redhat:rhel_extras_oracle_java:7:*:*:*:*:*:*:*

  • Configuration RedHat 7:
  • cpe:/a:redhat:rhel_extras:6:*:*:*:*:*:*:*

  • Configuration RedHat 8:
  • cpe:/a:redhat:rhel_extras:7:*:*:*:*:*:*:*

  • Configuration RedHat 9:
  • cpe:/a:redhat:rhel_extras:5:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20146587
    V
    CVE-2014-6587
    2017-09-24
    oval:org.cisecurity:def:180
    P
    DSA-3144-1 -- openjdk-7 -- security update
    2016-02-08
    oval:org.cisecurity:def:260
    P
    DSA-3147-1 -- openjdk-6 -- security update
    2016-02-08
    oval:org.mitre.oval:def:28009
    V
    JRE and JDK Vulnerability on HPUX
    2015-06-08
    oval:org.mitre.oval:def:28814
    V
    Potential security vulnerabilities have been identified in the Java RuntimeEnvironment (JRE) and the Java Developer Kit (JDK) running on HP-UX. These vulnerabilitiescould allow remote unauthorized access, disclosure of information, and othervulnerabilities.
    2015-05-11
    oval:org.mitre.oval:def:28819
    V
    Potential security vulnerabilities have been identified in the Java RuntimeEnvironment (JRE) and the Java Developer Kit (JDK) running on HP-UX. These vulnerabilitiescould allow remote unauthorized access, disclosure of information, and othervulnerabilities.
    2015-05-11
    oval:org.mitre.oval:def:28179
    V
    Multiple vulnerabilities in current releases of the IBM® SDK,Java TechnologyEdition
    2015-04-13
    oval:com.redhat.rhsa:def:20150133
    P
    RHSA-2015:0133: java-1.7.1-ibm security update (Critical)
    2015-02-05
    oval:com.redhat.rhsa:def:20150134
    P
    RHSA-2015:0134: java-1.7.0-ibm security update (Critical)
    2015-02-05
    oval:com.redhat.rhsa:def:20150135
    P
    RHSA-2015:0135: java-1.6.0-ibm security update (Critical)
    2015-02-05
    oval:com.redhat.rhsa:def:20150085
    P
    RHSA-2015:0085: java-1.6.0-openjdk security update (Important)
    2015-01-26
    oval:com.redhat.rhsa:def:20150086
    P
    RHSA-2015:0086: java-1.6.0-sun security update (Important)
    2015-01-26
    oval:com.redhat.rhsa:def:20150080
    P
    RHSA-2015:0080: java-1.8.0-oracle security update (Critical)
    2015-01-22
    oval:com.redhat.rhsa:def:20150079
    P
    RHSA-2015:0079: java-1.7.0-oracle security update (Critical)
    2015-01-22
    oval:com.redhat.rhsa:def:20150067
    P
    RHSA-2015:0067: java-1.7.0-openjdk security update (Critical)
    2015-01-21
    oval:com.ubuntu.trusty:def:20146587000
    V
    CVE-2014-6587 on Ubuntu 14.04 LTS (trusty) - medium.
    2015-01-21
    oval:com.redhat.rhsa:def:20150069
    P
    RHSA-2015:0069: java-1.8.0-openjdk security update (Important)
    2015-01-21
    oval:com.ubuntu.precise:def:20146587000
    V
    CVE-2014-6587 on Ubuntu 12.04 LTS (precise) - medium.
    2015-01-21
    oval:com.redhat.rhsa:def:20150068
    P
    RHSA-2015:0068: java-1.7.0-openjdk security update (Important)
    2015-01-20
    BACK
    oracle jdk 1.6.0 update_85
    oracle jre 1.6.0 update_85
    oracle jre 1.7.0 update_72
    oracle jdk 1.7.0 update_72
    oracle jre 1.8.0 update_25
    oracle jdk 1.8.0 update_25
    redhat enterprise_linux 7
    redhat enterprise_linux 6
    redhat enterprise_linux 5
    redhat rhel_extras_oracle_java 6
    redhat rhel_extras_oracle_java 5
    redhat rhel_extras_oracle_java 7
    redhat rhel_extras 6
    redhat rhel_extras 7
    redhat rhel_extras 5