Vulnerability Name:

CVE-2014-8147

Assigned:2014-10-10
Published:2015-05-25
Updated:2016-12-21
Summary:The resolveImplicitLevels function in common/ubidi.c in the Unicode Bidirectional Algorithm implementation in ICU4C in International Components for Unicode (ICU) before 55.1 uses an integer data type that is inconsistent with a header file, which allows remote attackers to cause a denial of service (incorrect malloc followed by invalid free) or possibly execute arbitrary code via crafted text.
CVSS v3 Severity:7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:7.5 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-189
References:Source: CONFIRM
Type: UNKNOWN
http://bugs.icu-project.org/trac/changeset/37080

Source: APPLE
Type: UNKNOWN
http://lists.apple.com/archives/security-announce/2015/Sep/msg00005.html

Source: APPLE
Type: UNKNOWN
http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html

Source: MLIST
Type: UNKNOWN
http://openwall.com/lists/oss-security/2015/05/05/6

Source: FULLDISC
Type: UNKNOWN
20150505 [CVE-2014-8146/8147] - ICU heap and integer overflows / I-C-U-FAIL

Source: DEBIAN
Type: UNKNOWN
http://www.debian.org/security/2015/dsa-3323

Source: CERT-VN
Type: VENDOR_ADVISORY
http://www.kb.cert.org/vuls/id/602540

Source: CONFIRM
Type: UNKNOWN
http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html

Source: CONFIRM
Type: PATCH
http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html

Source: BID
Type: UNKNOWN
74457

Source: MISC
Type: UNKNOWN
https://raw.githubusercontent.com/pedrib/PoC/master/generic/i-c-u-fail.txt

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201507-04

Source: CONFIRM
Type: UNKNOWN
https://support.apple.com/HT205213

Source: CONFIRM
Type: UNKNOWN
https://support.apple.com/HT205267

Vulnerable Configuration:Configuration 1:
  • cpe:/o:apple:mac_os_x:10.10.4:*:*:*:*:*:*:*
  • OR cpe:/o:apple:watchos:1.0.1:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:icu_project:international_components_for_unicode:52.0:*:*:*:*:*:*:*
  • OR cpe:/a:icu_project:international_components_for_unicode:53.0:*:*:*:*:*:*:*
  • OR cpe:/a:icu_project:international_components_for_unicode:54.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20148147
    V
    CVE-2014-8147
    2017-09-24
    oval:org.cisecurity:def:51
    P
    DSA-3323-1 -- icu -- security update
    2016-02-08
    oval:com.ubuntu.precise:def:20148147000
    V
    CVE-2014-8147 on Ubuntu 12.04 LTS (precise) - medium.
    2015-05-25
    oval:com.ubuntu.trusty:def:20148147000
    V
    CVE-2014-8147 on Ubuntu 14.04 LTS (trusty) - medium.
    2015-05-25
    BACK
    apple mac_os_x 10.10.4
    apple watchos 1.0.1
    icu_project international_components_for_unicode 52.0
    icu_project international_components_for_unicode 53.0
    icu_project international_components_for_unicode 54.0