Vulnerability Name:

CVE-2014-9066

Assigned:2014-11-24
Published:2014-12-09
Updated:2016-12-21
Summary:Xen 4.4.x and earlier, when using a large number of VCPUs, does not properly handle read and write locks, which allows local x86 guest users to cause a denial of service (write denial or NMI watchdog timeout and host crash) via a large number of read requests, a different vulnerability than CVE-2014-9065.
CVSS v3 Severity:5.1 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): High
CVSS v2 Severity:4.7 Medium (CVSS v2 Vector: AV:L/AC:M/Au:N/C:N/I:N/A:C)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Complete
Vulnerability Type:CWE-17
References:Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00005.html

Source: SUSE
Type: UNKNOWN
http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00010.html

Source: MLIST
Type: UNKNOWN
http://www.openwall.com/lists/oss-security/2014/12/08/4

Source: BID
Type: UNKNOWN
71546

Source: CONFIRM
Type: VENDOR_ADVISORY
http://xenbits.xen.org/xsa/advisory-114.html

Source: GENTOO
Type: UNKNOWN
https://security.gentoo.org/glsa/201504-04

Vulnerable Configuration:Configuration 1:
  • cpe:/o:xen:xen:4.4.1:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/o:novell:opensuse:13.2:*:*:*:*:*:*:*
  • OR cpe:/o:novell:opensuse:13.1:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20149066
    V
    CVE-2014-9066
    2017-09-24
    oval:com.ubuntu.precise:def:20149066000
    V
    CVE-2014-9066 on Ubuntu 12.04 LTS (precise) - medium.
    2014-12-09
    oval:com.ubuntu.trusty:def:20149066000
    V
    CVE-2014-9066 on Ubuntu 14.04 LTS (trusty) - medium.
    2014-12-09
    BACK
    xen xen 4.4.1
    novell opensuse 13.2
    novell opensuse 13.1