Vulnerability Name:

CVE-2015-5219

Assigned:2015-08-25
Published:2015-08-25
Updated:2018-05-17
Summary:The ULOGTOD function in ntp.d in SNTP before 4.2.7p366 does not properly perform type conversions from a precision value to a double, which allows remote attackers to cause a denial of service (infinite loop) via a crafted NTP packet.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): High
4.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
3.8 Low (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Adjacent
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
3.3 Low (CCN CVSS v2 Vector: AV:A/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Adjacent_Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
3.3 Low (REDHAT CVSS v2 Vector: AV:A/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Adjacent_Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
Vulnerability Type:CWE-704
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://aix.software.ibm.com/aix/efixes/security/ntp_advisory4.asc

Source: CONFIRM
Type: VENDOR_ADVISORY
http://bk1.ntp.org/ntp-dev/?PAGE=patch&REV=51786731Gr4-NOrTBC_a_uXO4wuGhg

Source: FEDORA
Type: VENDOR_ADVISORY
FEDORA-2015-77bfbc1bcd

Source: FEDORA
Type: VENDOR_ADVISORY
FEDORA-2015-14212

Source: FEDORA
Type: VENDOR_ADVISORY
FEDORA-2015-14213

Source: SUSE
Type: VENDOR_ADVISORY
SUSE-SU:2016:1311

Source: SUSE
Type: VENDOR_ADVISORY
openSUSE-SU:2016:3280

Source: REDHAT
Type: VENDOR_ADVISORY
RHSA-2016:0780

Source: REDHAT
Type: VENDOR_ADVISORY
RHSA-2016:2583

Source: DEBIAN
Type: VENDOR_ADVISORY
DSA-3388

Source: MLIST
Type: VENDOR_ADVISORY
[oss-security] 20150825 Several low impact ntp.org ntpd issues

Source: CONFIRM
Type: UNKNOWN
http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html

Source: BID
Type: VENDOR_ADVISORY
76473

Source: UBUNTU
Type: VENDOR_ADVISORY
USN-2783-1

Source: CONFIRM
Type: UNKNOWN
https://bugzilla.redhat.com/show_bug.cgi?id=1255118

Source: XF
Type: UNKNOWN
ntp-cve20155219-dos(107597)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/ntp-project/ntp/commit/5f295cd05c3c136d39f5b3e500a2d781bdbb59c8

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www-01.ibm.com/support/docview.wss?uid=isg3T1024157

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www-01.ibm.com/support/docview.wss?uid=swg21985122

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www-01.ibm.com/support/docview.wss?uid=swg21986956

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www-01.ibm.com/support/docview.wss?uid=swg21988706

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www-01.ibm.com/support/docview.wss?uid=swg21989542

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www.ibm.com/support/home/docdisplay?lndocid=migr-5099409

Vulnerable Configuration:Configuration 1:
  • cpe:/o:fedoraproject:fedora:21:*:*:*:*:*:*:*
  • OR cpe:/o:fedoraproject:fedora:22:*:*:*:*:*:*:*
  • OR cpe:/o:fedoraproject:fedora:23:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:suse:linux_enterprise_debuginfo:11:sp2:*:*:*:*:*:*
  • OR cpe:/a:suse:linux_enterprise_debuginfo:11:sp3:*:*:*:*:*:*
  • OR cpe:/o:suse:linux_enterprise_server:10:sp4:~~ltss~~~:*:*:*:*:*
  • OR cpe:/o:suse:linux_enterprise_server:11:sp2:~~ltss~~~:*:*:*:*:*
  • OR cpe:/o:suse:linux_enterprise_server:11:sp3:~~ltss~~~:*:*:*:*:*
  • OR cpe:/o:suse:manager:2.1:*:*:*:*:*:*:*
  • OR cpe:/o:suse:manager_proxy:2.1:*:*:*:*:*:*:*
  • OR cpe:/o:suse:openstack_cloud:5:*:*:*:*:*:*:*

  • Configuration 3:
  • cpe:/o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_hpc_node:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_hpc_node:7.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*

  • Configuration 4:
  • cpe:/o:debian:debian_linux:7.0:*:*:*:*:*:*:*
  • OR cpe:/o:debian:debian_linux:8.0:*:*:*:*:*:*:*

  • Configuration 5:
  • cpe:/o:canonical:ubuntu_linux:12.04::~~lts~~~:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:*

  • Configuration 6:
  • cpe:/a:ntp:ntp:4.2.7:p355:*:*:*:*:*:*

  • Configuration 7:
  • cpe:/o:novell:leap:42.1:*:*:*:*:*:*:*
  • OR cpe:/o:novell:leap:42.2:*:*:*:*:*:*:*

  • Configuration RedHat 1:
  • cpe:/o:redhat:enterprise_linux:6:*:*:*:*:*:*:*

  • Configuration RedHat 2:
  • cpe:/o:redhat:enterprise_linux:7:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20155219
    V
    CVE-2015-5219
    2018-05-25
    oval:com.ubuntu.trusty:def:20155219000
    V
    CVE-2015-5219 on Ubuntu 14.04 LTS (trusty) - low.
    2017-07-21
    oval:com.redhat.rhsa:def:20162583
    P
    RHSA-2016:2583: ntp security and bug fix update (Moderate)
    2016-11-03
    oval:com.redhat.rhsa:def:20160780
    P
    RHSA-2016:0780: ntp security and bug fix update (Moderate)
    2016-05-10
    oval:org.cisecurity:def:402
    V
    Network Time Protocol (NTP) vulnerability in AIX
    2016-03-11
    oval:org.cisecurity:def:304
    P
    DSA-3388-1 ntp -- security update
    2016-02-08
    oval:com.ubuntu.precise:def:20155219000
    V
    CVE-2015-5219 on Ubuntu 12.04 LTS (precise) - low.
    2015-08-25
    BACK
    fedoraproject fedora 21
    fedoraproject fedora 22
    fedoraproject fedora 23
    suse linux enterprise debuginfo 11 sp2
    suse linux enterprise debuginfo 11 sp3
    suse linux enterprise server 10 sp4
    suse linux enterprise server 11 sp2
    suse linux enterprise server 11 sp3
    suse manager 2.1
    suse manager proxy 2.1
    suse openstack cloud 5
    redhat enterprise linux desktop 6.0
    redhat enterprise linux desktop 7.0
    redhat enterprise linux hpc node 6.0
    redhat enterprise linux hpc node 7.0
    redhat enterprise linux server 6.0
    redhat enterprise linux server 7.0
    redhat enterprise linux workstation 6.0
    redhat enterprise linux workstation 7.0
    debian debian linux 7.0
    debian debian linux 8.0
    canonical ubuntu linux 12.04
    canonical ubuntu linux 14.04
    canonical ubuntu linux 15.04
    canonical ubuntu linux 15.10
    ntp ntp 4.2.7 p355
    novell leap 42.1
    novell leap 42.2