Vulnerability Name:

CVE-2016-10327

Assigned:2017-04-14
Published:2017-04-14
Updated:2017-11-14
Summary:LibreOffice before 2016-12-22 has an out-of-bounds write caused by a heap-based buffer overflow related to the EnhWMFReader::ReadEnhWMF function in vcl/source/filter/wmf/enhwmf.cxx.
CVSS v3 Severity:9.8 Critical (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
8.5 High (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
6.4 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:7.5 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
7.5 High (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-787
References:Source: CONFIRM
Type: UNKNOWN
http://www.libreoffice.org/about-us/security/advisories/cve-2016-10327/

Source: BID
Type: VENDOR_ADVISORY
97668

Source: MISC
Type: VENDOR_ADVISORY
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=313

Source: XF
Type: UNKNOWN
libreoffice-cve201610327-bo(126661)

Source: MISC
Type: VENDOR_ADVISORY
https://github.com/LibreOffice/core/commit/7485fc2a1484f31631f62f97e5c64c0ae74c6416

Source: GENTOO
Type: UNKNOWN
GLSA-201706-28

Vulnerable Configuration:Configuration 1:
  • cpe:/a:libreoffice:libreoffice:5.3.0.0:beta2:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:201610327
    V
    CVE-2016-10327
    2017-11-24
    oval:com.ubuntu.xenial:def:201610327000
    V
    CVE-2016-10327 on Ubuntu 16.04 LTS (xenial) - medium.
    2017-04-14
    oval:com.ubuntu.trusty:def:201610327000
    V
    CVE-2016-10327 on Ubuntu 14.04 LTS (trusty) - medium.
    2017-04-14
    oval:com.ubuntu.precise:def:201610327000
    V
    CVE-2016-10327 on Ubuntu 12.04 LTS (precise) - medium.
    2017-04-14
    BACK
    libreoffice libreoffice 5.3.0.0 beta2