Vulnerability Name:

CVE-2016-10397

Assigned:2017-07-10
Published:2016-09-28
Updated:2018-01-13
Summary:In PHP before 5.6.28 and 7.x before 7.0.13, incorrect handling of various URI components in the URL parser could be used by attackers to bypass hostname-specific URL checks, as demonstrated by evil.example.com:80#@good.example.com/ and evil.example.com:80?@good.example.com/ inputs to the parse_url function (implemented in the php_url_parse_ex function in ext/standard/url.c).
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
4.6 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-20
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://git.php.net/?p=php-src.git;a=commit;h=b061fa909de77085d3822a89ab901b934d0362c4

Source: CONFIRM
Type: VENDOR_ADVISORY
http://openwall.com/lists/oss-security/2017/07/10/6

Source: CONFIRM
Type: VENDOR_ADVISORY
http://php.net/ChangeLog-5.php

Source: CONFIRM
Type: VENDOR_ADVISORY
http://php.net/ChangeLog-7.php

Source: BID
Type: UNKNOWN
99552

Source: CONFIRM
Type: VENDOR_ADVISORY
https://bugs.php.net/bug.php?id=73192

Source: XF
Type: UNKNOWN
php-cve201610397-sec-bypass(129428)

Source: CONFIRM
Type: UNKNOWN
https://security.netapp.com/advisory/ntap-20180112-0001/

Vulnerable Configuration:Configuration 1:
  • cpe:/a:php:php:5.6.27:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.3:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.4:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.5:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.6:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.7:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.8:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.9:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.10:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.11:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:7.0.12:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:php:php:7.0.12:*:*:*:*:*:*:*
  • OR cpe:/a:php:php:5.6.27:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:201610397
    V
    CVE-2016-10397
    2018-01-23
    oval:com.ubuntu.trusty:def:201610397000
    V
    CVE-2016-10397 on Ubuntu 14.04 LTS (trusty) - medium.
    2017-07-10
    oval:com.ubuntu.xenial:def:201610397000
    V
    CVE-2016-10397 on Ubuntu 16.04 LTS (xenial) - medium.
    2017-07-10
    BACK
    php php 5.6.27
    php php 7.0.0
    php php 7.0.1
    php php 7.0.2
    php php 7.0.3
    php php 7.0.4
    php php 7.0.5
    php php 7.0.6
    php php 7.0.7
    php php 7.0.8
    php php 7.0.9
    php php 7.0.10
    php php 7.0.11
    php php 7.0.12