Vulnerability Name:

CVE-2017-1000421

Assigned:2018-01-02
Published:2017-08-10
Updated:2018-02-03
Summary:Gifsicle gifview 1.89 and older is vulnerable to a use-after-free in the read_gif function resulting potential code execution
CVSS v3 Severity:9.8 Critical (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
8.5 High (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
6.4 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:7.5 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
7.5 High (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-416
References:Source: XF
Type: UNKNOWN
gifsicle-cve20171000421-code-exec(137237)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/kohler/gifsicle/issues/114

Source: MLIST
Type: UNKNOWN
[debian-lts-announce] 20180108 [SECURITY] [DLA 1233-1] gifsicle security update

Source: DEBIAN
Type: VENDOR_ADVISORY
DSA-4084

Vulnerable Configuration:Configuration 1:
  • cpe:/a:gifsicle_project:gifsicle:1.89:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/o:debian:debian_linux:8.0:*:*:*:*:*:*:*
  • OR cpe:/o:debian:debian_linux:9.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.xenial:def:20171000421000
    V
    CVE-2017-1000421 on Ubuntu 16.04 LTS (xenial) - untriaged.
    2018-01-02
    oval:com.ubuntu.trusty:def:20171000421000
    V
    CVE-2017-1000421 on Ubuntu 14.04 LTS (trusty) - untriaged.
    2018-01-02
    oval:com.ubuntu.artful:def:20171000421000
    V
    CVE-2017-1000421 on Ubuntu 17.10 (artful) - untriaged.
    2018-01-02
    BACK
    gifsicle_project gifsicle 1.89
    debian debian linux 8.0
    debian debian linux 9.0