Vulnerability Name:

CVE-2017-1126

Assigned:2016-11-30
Published:2017-10-03
Updated:2017-10-13
Summary:IBM WebSphere Message Broker (IBM Integration Bus 9.0 and 10.0) could allow an unauthorized user to obtain sensitive information about software versions that could lead to further attacks. IBM X-Force ID: 121341.
CVSS v3 Severity:5.3 Medium (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): None
Availibility (A): None
5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
Vulnerability Type:CWE-200
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://www.ibm.com/support/docview.wss?uid=swg22008470

Source: BID
Type: VENDOR_ADVISORY
101104

Source: MISC
Type: VENDOR_ADVISORY
https://exchange.xforce.ibmcloud.com/vulnerabilities/121341

Vulnerable Configuration:Configuration 1:
  • cpe:/a:ibm:integration_bus:9.0.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.4:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.5:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.6:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.7:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:9.0.0.8:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.3:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.4:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.5:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.6:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.7:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.8:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:integration_bus:10.0.0.9:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.3:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.4:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.5:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.6:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.7:*:*:*:*:*:*:*
  • OR cpe:/a:ibm:websphere_message_broker:8.0.0.8:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    ibm integration_bus 9.0.0.0
    ibm integration_bus 9.0.0.1
    ibm integration_bus 9.0.0.2
    ibm integration_bus 9.0.0.4
    ibm integration_bus 9.0.0.5
    ibm integration_bus 9.0.0.6
    ibm integration_bus 9.0.0.7
    ibm integration_bus 9.0.0.8
    ibm integration_bus 10.0.0.0
    ibm integration_bus 10.0.0.1
    ibm integration_bus 10.0.0.2
    ibm integration_bus 10.0.0.3
    ibm integration_bus 10.0.0.4
    ibm integration_bus 10.0.0.5
    ibm integration_bus 10.0.0.6
    ibm integration_bus 10.0.0.7
    ibm integration_bus 10.0.0.8
    ibm integration_bus 10.0.0.9
    ibm websphere_message_broker 8.0.0.0
    ibm websphere_message_broker 8.0.0.1
    ibm websphere_message_broker 8.0.0.2
    ibm websphere_message_broker 8.0.0.3
    ibm websphere_message_broker 8.0.0.4
    ibm websphere_message_broker 8.0.0.5
    ibm websphere_message_broker 8.0.0.6
    ibm websphere_message_broker 8.0.0.7
    ibm websphere_message_broker 8.0.0.8