Vulnerability Name:

CVE-2017-12169

Assigned:2017-08-01
Published:2017-09-01
Updated:2018-04-16
Summary:It was found that FreeIPA 4.2.0 and later could disclose password hashes to users having the 'System: Read Stage Users' permission. A remote, authenticated attacker could potentially use this flaw to disclose the password hashes belonging to Stage Users. This security issue does not result in disclosure of password hashes belonging to active standard users. NOTE: some developers feel that this report is a suggestion for a design change to Stage User activation, not a statement of a vulnerability.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
6.6 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:U/RC:R)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
6.5 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N)
5.7 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:U/RC:R)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:4.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
6.8 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:C/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Complete
Integrity (I): None
Availibility (A): None
Vulnerability Type:CWE-200
References:Source: BID
Type: VENDOR_ADVISORY
102136

Source: CONFIRM
Type: VENDOR_ADVISORY
https://bugzilla.redhat.com/show_bug.cgi?id=1487697

Source: XF
Type: UNKNOWN
freeipa-cve201712169-info-disc(137385)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:freeipa:freeipa:4.2.0:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.2.2:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.2.3:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.2.4:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.3.0:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.3.1:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.3.2:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.3.3:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.4.1:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.4.2:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.4.3:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.4.4:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.5.1:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.5.2:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.5.3:*:*:*:*:*:*:*
  • OR cpe:/a:freeipa:freeipa:4.6.1:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.xenial:def:201712169000
    V
    CVE-2017-12169 on Ubuntu 16.04 LTS (xenial) - low.
    2018-01-10
    oval:com.ubuntu.trusty:def:201712169000
    V
    CVE-2017-12169 on Ubuntu 14.04 LTS (trusty) - low.
    2018-01-10
    oval:com.ubuntu.artful:def:201712169000
    V
    CVE-2017-12169 on Ubuntu 17.10 (artful) - low.
    2018-01-10
    BACK
    freeipa freeipa 4.2.0
    freeipa freeipa 4.2.2
    freeipa freeipa 4.2.3
    freeipa freeipa 4.2.4
    freeipa freeipa 4.3.0
    freeipa freeipa 4.3.1
    freeipa freeipa 4.3.2
    freeipa freeipa 4.3.3
    freeipa freeipa 4.4.1
    freeipa freeipa 4.4.2
    freeipa freeipa 4.4.3
    freeipa freeipa 4.4.4
    freeipa freeipa 4.5.1
    freeipa freeipa 4.5.2
    freeipa freeipa 4.5.3
    freeipa freeipa 4.6.1