Vulnerability Name:

CVE-2017-12732

Assigned:2017-08-09
Published:2017-10-05
Updated:2017-10-13
Summary:A Stack-based Buffer Overflow issue was discovered in GE CIMPLICITY Versions 9.0 and prior. A function reads a packet to indicate the next packet length. The next packet length is not verified, allowing a buffer overwrite that could lead to an arbitrary remote code execution.
CVSS v3 Severity:5.9 Medium (CVSS v3 Vector: CVSS:3.0/AV:/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H)
Exploitability Metrics:Attack Vector (AV): 
Attack Complexity (AC): High
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
4.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:A/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Adjacent
Attack Complexity (AC): High
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:4.9 Medium (CVSS v2 Vector: AV:A/AC:M/Au:S/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Adjacent_Network
Access Complexity (AC): Medium
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-119
References:Source: BID
Type: VENDOR_ADVISORY
101174

Source: MISC
Type: VENDOR_ADVISORY
https://ics-cert.us-cert.gov/advisories/ICSA-17-278-01

Vulnerable Configuration:Configuration 1:
  • cpe:/a:ge:intelligent_platforms_proficy_hmi/scada_cimplicity:9.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    ge intelligent_platforms_proficy_hmi/scada_cimplicity 9.0