Vulnerability Name:

CVE-2017-13209

Assigned:2017-08-23
Published:2018-01-05
Updated:2018-01-13
Summary:In the ServiceManager::add function in the hardware service manager, there is an insecure permissions check based on the PID of the caller which could allow an application or service to replace a HAL service with its own service. This could lead to a local elevation of privilege enabling code execution as a privileged process with no additional execution privileges needed. User interaction is not needed for exploitation. Product: Android. Versions: 8.0, 8.1. Android ID: A-68217907.
CVSS v3 Severity:7.8 High (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
6.8 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
CVSS v2 Severity:6.8 Medium (CCN CVSS v2 Vector: AV:L/AC:L/Au:S/C:C/I:C/A:C)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
References:Source: BID
Type: UNKNOWN
102415

Source: SECTRACK
Type: UNKNOWN
1040106

Source: XF
Type: UNKNOWN
android-cve201713209-code-exec(137490)

Source: CONFIRM
Type: UNKNOWN
https://source.android.com/security/bulletin/2018-01-01

Source: EXPLOIT-DB
Type: UNKNOWN
43513

Vulnerable Configuration:
Configuration CCN 1:
  • cpe:/a:google:android_api:1.0:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK