Vulnerability Name:

CVE-2017-14622

Assigned:2017-09-20
Published:2017-09-27
Updated:2017-10-10
Summary:Multiple cross-site scripting (XSS) vulnerabilities in the 2kb Amazon Affiliates Store plugin before 2.1.1 for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) page parameter or (2) kbAction parameter in the kbAmz page to wp-admin/admin.php.
CVSS v3 Severity:6.1 Medium (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Changed
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): None
3.7 Low (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-79
References:Source: BID
Type: VENDOR_ADVISORY
101050

Source: MISC
Type: VENDOR_ADVISORY
https://packetstormsecurity.com/files/144261/WordPress-2kb-Amazon-Affiliates-Store-2.1.0-Cross-Site-Scripting.html

Source: CONFIRM
Type: VENDOR_ADVISORY
https://wordpress.org/plugins/2kb-amazon-affiliates-store/#developers

Vulnerable Configuration:Configuration 1:
  • cpe:/a:2kblater:2kb_amazon_affiliates_store:2.1.0::~~~wordpress~~:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    2kblater 2kb_amazon_affiliates_store 2.1.0