Vulnerability Name:

CVE-2017-14949

Assigned:2017-09-29
Published:2017-10-02
Updated:2017-12-15
Summary:Restlet Framework before 2.3.12 allows remote attackers to access arbitrary files via a crafted REST API HTTP request that conducts an XXE attack, because only general external entities (not parameter external entities) are properly considered. This is related to XmlRepresentation, DOMRepresentation, SaxRepresentation, and JacksonRepresentation.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
5.5 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N)
4.8 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
Vulnerability Type:CWE-611
References:Source: XF
Type: UNKNOWN
restlet-cve201714949-info-disc(135734)

Source: MISC
Type: VENDOR_ADVISORY
https://github.com/restlet/restlet-framework-java/wiki/XEE-security-enhancements

Source: MISC
Type: VENDOR_ADVISORY
https://lgtm.com/blog/restlet_CVE-2017-14949

Vulnerable Configuration:Configuration 1:
  • cpe:/a:restlet:restlet:2.1:milestone1:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:milestone2:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:milestone3:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:milestone4:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:milestone5:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:milestone6:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc1:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc2:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc3:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc4:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc5:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1:rc6:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1.0:*:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1.1:*:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1.2:*:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1.3:*:*:*:*:*:*:*
  • OR cpe:/a:restlet:restlet:2.1.4:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.xenial:def:201714949000
    V
    CVE-2017-14949 on Ubuntu 16.04 LTS (xenial) - untriaged.
    2017-11-30
    oval:com.ubuntu.trusty:def:201714949000
    V
    CVE-2017-14949 on Ubuntu 14.04 LTS (trusty) - untriaged.
    2017-11-30
    BACK
    restlet restlet 2.1 milestone1
    restlet restlet 2.1 milestone2
    restlet restlet 2.1 milestone3
    restlet restlet 2.1 milestone4
    restlet restlet 2.1 milestone5
    restlet restlet 2.1 milestone6
    restlet restlet 2.1 rc1
    restlet restlet 2.1 rc2
    restlet restlet 2.1 rc3
    restlet restlet 2.1 rc4
    restlet restlet 2.1 rc5
    restlet restlet 2.1 rc6
    restlet restlet 2.1.0
    restlet restlet 2.1.1
    restlet restlet 2.1.2
    restlet restlet 2.1.3
    restlet restlet 2.1.4