Vulnerability Name:

CVE-2017-15116

Assigned:2017-10-08
Published:2017-10-08
Updated:2017-11-30
Summary:The rngapi_reset function in crypto/rng.c in the Linux kernel before 4.2 allows attackers to cause a denial of service (NULL pointer dereference).
CVSS v3 Severity:5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
4.6 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:
References:Source: MISC
Type: UNKNOWN
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=94f1bb15bed84ad6c893916b7e7b9db6f1d7eec6

Source: MISC
Type: UNKNOWN
https://bugzilla.redhat.com/show_bug.cgi?id=1485815

Source: MISC
Type: UNKNOWN
https://bugzilla.redhat.com/show_bug.cgi?id=1514609

Source: XF
Type: UNKNOWN
linux-kernel-cve201715116-dos(135735)

Source: MISC
Type: UNKNOWN
https://github.com/torvalds/linux/commit/94f1bb15bed84ad6c893916b7e7b9db6f1d7eec6

Vulnerable Configuration:
Configuration CCN 1:
  • cpe:/o:linux:linux_kernel:4.1.3:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.xenial:def:201715116000
    V
    CVE-2017-15116 on Ubuntu 16.04 LTS (xenial) - low.
    2017-11-30
    oval:com.ubuntu.trusty:def:201715116000
    V
    CVE-2017-15116 on Ubuntu 14.04 LTS (trusty) - low.
    2017-11-30
    BACK