Vulnerability Name:

CVE-2017-4945

Assigned:2016-12-26
Published:2018-01-04
Updated:2018-01-19
Summary:VMware Workstation (14.x and 12.x) and Fusion (10.x and 8.x) contain a guest access control vulnerability. This issue may allow program execution via Unity on locked Windows VMs. VMware Tools must be updated to 10.2.0 for each VM to resolve CVE-2017-4945. VMware Tools 10.2.0 is consumed by Workstation 14.1.0 and Fusion 10.1.0 by default.
CVSS v3 Severity:5.5 Medium (CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N)
4.8 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
4.0 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
3.5 Low (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:2.1 Low (CVSS v2 Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
2.1 Low (CCN CVSS v2 Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-284
References:Source: BID
Type: VENDOR_ADVISORY
102441

Source: SECTRACK
Type: VENDOR_ADVISORY
1040109

Source: SECTRACK
Type: VENDOR_ADVISORY
1040136

Source: XF
Type: UNKNOWN
vmware-fusion-cve20174945-sec-bypass(137161)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www.vmware.com/us/security/advisories/VMSA-2018-0003.html

Vulnerable Configuration:Configuration 1:
  • cpe:/a:vmware:workstation:12.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.1.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.0:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.2:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.3:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.4:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.5:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.6:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.7:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.8:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:12.5.9:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:workstation:14.0:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:vmware:fusion:8.0:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.1.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.2:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.3:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.4:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.5:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.6:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.7:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.8:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.9:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:8.5.10:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:10.0:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:10.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:10.1.0:*:*:*:*:*:*:*
  • OR cpe:/a:vmware:fusion:10.1.1:*:*:*:*:*:*:*
  • AND
  • cpe:/o:apple:mac_os_x:-:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:vmware:fusion:8.1:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    vmware workstation 12.0.0
    vmware workstation 12.0.1
    vmware workstation 12.1
    vmware workstation 12.1.1
    vmware workstation 12.5
    vmware workstation 12.5.0
    vmware workstation 12.5.1
    vmware workstation 12.5.2
    vmware workstation 12.5.3
    vmware workstation 12.5.4
    vmware workstation 12.5.5
    vmware workstation 12.5.6
    vmware workstation 12.5.7
    vmware workstation 12.5.8
    vmware workstation 12.5.9
    vmware workstation 14.0
    vmware fusion 8.0
    vmware fusion 8.0.1
    vmware fusion 8.0.2
    vmware fusion 8.1
    vmware fusion 8.1.1
    vmware fusion 8.5
    vmware fusion 8.5.1
    vmware fusion 8.5.2
    vmware fusion 8.5.3
    vmware fusion 8.5.4
    vmware fusion 8.5.5
    vmware fusion 8.5.6
    vmware fusion 8.5.7
    vmware fusion 8.5.8
    vmware fusion 8.5.9
    vmware fusion 8.5.10
    vmware fusion 10.0
    vmware fusion 10.0.1
    vmware fusion 10.1.0
    vmware fusion 10.1.1
    apple mac_os_x -