Vulnerability Name:

CVE-2017-7272

Assigned:2017-03-27
Published:2017-03-27
Updated:2018-02-25
Summary:PHP through 7.1.11 enables potential SSRF in applications that accept an fsockopen or pfsockopen hostname argument with an expectation that the port number is constrained. Because a :port syntax is recognized, fsockopen will use the port number that is specified in the hostname argument, instead of the port number in the second argument of the function.
CVSS v3 Severity:7.4 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N)
6.4 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Changed
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
4.6 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:5.8 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): None
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-918
References:Source: BID
Type: VENDOR_ADVISORY
97178

Source: SECTRACK
Type: UNKNOWN
1038158

Source: CONFIRM
Type: VENDOR_ADVISORY
https://bugs.php.net/bug.php?id=74216

Source: CONFIRM
Type: UNKNOWN
https://bugs.php.net/bug.php?id=75505

Source: XF
Type: UNKNOWN
php-cve20177272-ssrf(123821)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/php/php-src/commit/bab0b99f376dac9170ac81382a5ed526938d595a

Source: CONFIRM
Type: UNKNOWN
https://security.netapp.com/advisory/ntap-20180112-0001/

Source: MISC
Type: UNKNOWN
https://www.sec-consult.com/fxdata/seccons/prod/temedia/advisories_txt/20170403-0_PHP_Misbehavior_of_fsockopen_function_v10.txt

Vulnerable Configuration:Configuration 1:
  • cpe:/a:php:php:7.1.3:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:php:php:7.1.3:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20177272
    V
    CVE-2017-7272
    2018-04-25
    oval:com.ubuntu.precise:def:20177272000
    V
    CVE-2017-7272 on Ubuntu 12.04 LTS (precise) - low.
    2017-03-27
    oval:com.ubuntu.trusty:def:20177272000
    V
    CVE-2017-7272 on Ubuntu 14.04 LTS (trusty) - low.
    2017-03-27
    oval:com.ubuntu.xenial:def:20177272000
    V
    CVE-2017-7272 on Ubuntu 16.04 LTS (xenial) - low.
    2017-03-27
    BACK
    php php 7.1.3
    php php 7.1.3