Vulnerability Name:

CVE-2017-7548

Assigned:2017-04-05
Published:2017-08-10
Updated:2017-12-30
Summary:PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers with no privileges on a large object to overwrite the entire contents of the object, resulting in a denial of service.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
7.5 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N)
6.5 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
CVSS v2 Severity:4.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
7.8 High (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:C/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Complete
Availibility (A): None
Vulnerability Type:CWE-285
References:Source: DEBIAN
Type: UNKNOWN
DSA-3935

Source: DEBIAN
Type: UNKNOWN
DSA-3936

Source: BID
Type: VENDOR_ADVISORY
100276

Source: SECTRACK
Type: VENDOR_ADVISORY
1039142

Source: REDHAT
Type: UNKNOWN
RHSA-2017:2677

Source: REDHAT
Type: UNKNOWN
RHSA-2017:2678

Source: XF
Type: UNKNOWN
postgresql-cve20177548-sec-bypass(130242)

Source: GENTOO
Type: UNKNOWN
GLSA-201710-06

Source: CONFIRM
Type: VENDOR_ADVISORY
https://www.postgresql.org/about/news/1772/

Vulnerable Configuration:Configuration 1:
  • cpe:/a:postgresql:postgresql:9.4:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.1:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.2:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.3:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.4:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.5:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.6:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.7:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.8:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.9:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.10:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.11:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.12:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:postgresql:postgresql:9.5:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.1.:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.2:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.3:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.4:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.5:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.6:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.7:*:*:*:*:*:*:*

  • Configuration 3:
  • cpe:/a:postgresql:postgresql:9.6:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.6.1:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.6.2:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.6.3:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:postgresql:postgresql:9.6.3:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.5.7:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.4.12:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.3.17:*:*:*:*:*:*:*
  • OR cpe:/a:postgresql:postgresql:9.2.21:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20177548
    V
    CVE-2017-7548
    2018-01-23
    oval:com.ubuntu.xenial:def:20177548000
    V
    CVE-2017-7548 on Ubuntu 16.04 LTS (xenial) - medium.
    2017-08-16
    oval:com.ubuntu.trusty:def:20177548000
    V
    CVE-2017-7548 on Ubuntu 14.04 LTS (trusty) - medium.
    2017-08-16
    BACK
    postgresql postgresql 9.4
    postgresql postgresql 9.4.1
    postgresql postgresql 9.4.2
    postgresql postgresql 9.4.3
    postgresql postgresql 9.4.4
    postgresql postgresql 9.4.5
    postgresql postgresql 9.4.6
    postgresql postgresql 9.4.7
    postgresql postgresql 9.4.8
    postgresql postgresql 9.4.9
    postgresql postgresql 9.4.10
    postgresql postgresql 9.4.11
    postgresql postgresql 9.4.12
    postgresql postgresql 9.5
    postgresql postgresql 9.5.1.
    postgresql postgresql 9.5.2
    postgresql postgresql 9.5.3
    postgresql postgresql 9.5.4
    postgresql postgresql 9.5.5
    postgresql postgresql 9.5.6
    postgresql postgresql 9.5.7
    postgresql postgresql 9.6
    postgresql postgresql 9.6.1
    postgresql postgresql 9.6.2
    postgresql postgresql 9.6.3