Vulnerability Name:

CVE-2017-9807

Assigned:2017-06-21
Published:2017-06-21
Updated:2017-10-12
Summary:An issue was discovered in the OpenWebif plugin through 1.2.4 for E2 open devices. The saveConfig function of "plugin/controllers/models/config.py" performs an eval() call on the contents of the "key" HTTP GET parameter. This allows an unauthenticated remote attacker to execute arbitrary Python code or OS commands via api/saveconfig.
CVSS v3 Severity:9.8 Critical (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
10.0 Critical (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Changed
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
CVSS v2 Severity:10.0 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
Vulnerability Type:CWE-94
References:Source: MLIST
Type: UNKNOWN
http://www.openwall.com/lists/oss-security/2017/10/02/4

Source: BID
Type: VENDOR_ADVISORY
99232

Source: MISC
Type: UNKNOWN
https://census-labs.com/news/2017/10/02/e2openplugin-openwebif-saveconfig-remote-code-execution/

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/E2OpenPlugins/e2openplugin-OpenWebif/issues/620

Vulnerable Configuration:Configuration 1:
  • cpe:/a:openwebif_project:openwebif:1.2.4:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    openwebif_project openwebif 1.2.4