Vulnerability Name:

CVE-2018-0591

Assigned:2017-11-27
Published:2018-05-11
Updated:2018-06-25
Summary:The KINEPASS App for Android Ver 3.1.1 and earlier, and for iOS Ver 3.1.2 and earlier do not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.
CVSS v3 Severity:5.9 Medium (CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N)
5.2 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
4.8 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N)
4.2 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
4.0 Medium (CCN CVSS v2 Vector: AV:N/AC:H/Au:N/C:P/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): High
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-295
References:Source: XF
Type: UNKNOWN
kinepass-cve20180591-mitm(143188)

Source: MISC
Type: VENDOR_ADVISORY
https://itunes.apple.com/us/app/kinepasu-apuridekantan-bian/id637453055?mt=8

Source: JVN
Type: VENDOR_ADVISORY
JVN#83671755

Source: MISC
Type: VENDOR_ADVISORY
https://play.google.com/store/apps/details?id=jp.tjoy.kinepass&hl=en

Vulnerable Configuration:Configuration 1:
  • cpe:/a:t-joy:kinepass:3.1.1::~~~android~~:*:*:*:*:*
  • OR cpe:/a:t-joy:kinepass:3.1.2::~~~iphone_os~~:*:*:*:*:*

  • Denotes that component is vulnerable
    BACK
    t-joy kinepass 3.1.1
    t-joy kinepass 3.1.2