Vulnerability Name:

CVE-2018-1000168

Assigned:2018-04-13
Published:2018-04-13
Updated:2018-06-14
Summary:nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): High
5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
4.6 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
Vulnerability Type:CWE-476
References:Source: XF
Type: UNKNOWN
nghttp2-cve20181000168-dos(141584)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/

Source: CONFIRM
Type: UNKNOWN
https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/

Vulnerable Configuration:Configuration 1:
  • cpe:/a:nghttp2:nghttp2:1.10.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.11.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.11.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.12.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.13.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.14.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.14.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.15.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.16.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.16.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.17.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.18.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.18.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.19.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.20.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.21.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.21.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.22.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.23.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.23.1:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.24.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.25.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.26.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.27.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.28.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.29.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.30.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.31.0:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:nghttp2:nghttp2:1.10.0:*:*:*:*:*:*:*
  • OR cpe:/a:nghttp2:nghttp2:1.31.0:*:*:*:*:*:*:*
  • AND
  • cpe:/o:ibm:i:6.1:*:*:*:*:*:*:*

  • Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20181000168
    V
    CVE-2018-1000168
    2018-07-19
    oval:com.ubuntu.artful:def:20181000168000
    V
    CVE-2018-1000168 on Ubuntu 17.10 (artful) - medium.
    2018-05-08
    oval:com.ubuntu.xenial:def:20181000168000
    V
    CVE-2018-1000168 on Ubuntu 16.04 LTS (xenial) - medium.
    2018-05-08
    BACK
    nghttp2 nghttp2 1.10.0
    nghttp2 nghttp2 1.11.0
    nghttp2 nghttp2 1.11.1
    nghttp2 nghttp2 1.12.0
    nghttp2 nghttp2 1.13.0
    nghttp2 nghttp2 1.14.0
    nghttp2 nghttp2 1.14.1
    nghttp2 nghttp2 1.15.0
    nghttp2 nghttp2 1.16.0
    nghttp2 nghttp2 1.16.1
    nghttp2 nghttp2 1.17.0
    nghttp2 nghttp2 1.18.0
    nghttp2 nghttp2 1.18.1
    nghttp2 nghttp2 1.19.0
    nghttp2 nghttp2 1.20.0
    nghttp2 nghttp2 1.21.0
    nghttp2 nghttp2 1.21.1
    nghttp2 nghttp2 1.22.0
    nghttp2 nghttp2 1.23.0
    nghttp2 nghttp2 1.23.1
    nghttp2 nghttp2 1.24.0
    nghttp2 nghttp2 1.25.0
    nghttp2 nghttp2 1.26.0
    nghttp2 nghttp2 1.27.0
    nghttp2 nghttp2 1.28.0
    nghttp2 nghttp2 1.29.0
    nghttp2 nghttp2 1.30.0
    nghttp2 nghttp2 1.31.0
    nghttp2 nghttp2 1.10.0
    nghttp2 nghttp2 1.31.0
    ibm i 6.1