Vulnerability Name:

CVE-2018-1287

Assigned:2017-12-07
Published:2018-02-11
Updated:2018-02-20
Summary:In Apache JMeter 2.X and 3.X, when using Distributed Test only (RMI based), jmeter server binds RMI Registry to wildcard host. This could allow an attacker to get Access to JMeterEngine and send unauthorized code.
CVSS v3 Severity:6.5 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N)
5.7 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:6.4 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): None
References:Source: MLIST
Type: UNKNOWN
[www-announce] 20180211 CVE-2018-1287: Apache JMeter binds RMI server to wildcard in distributed mode (based on RMI)

Source: BID
Type: UNKNOWN
103068

Source: XF
Type: UNKNOWN
apache-jmeter-cve20181287-sec-bypass(138952)

Oval Definitions
Definition IDClassTitleLast Modified
oval:com.ubuntu.trusty:def:20181287000
V
CVE-2018-1287 on Ubuntu 14.04 LTS (trusty) - untriaged.
2018-02-14
oval:com.ubuntu.xenial:def:20181287000
V
CVE-2018-1287 on Ubuntu 16.04 LTS (xenial) - untriaged.
2018-02-14
oval:com.ubuntu.artful:def:20181287000
V
CVE-2018-1287 on Ubuntu 17.10 (artful) - untriaged.
2018-02-14
BACK