Vulnerability Name:

CVE-1999-1269 (CCN-1641)

Assigned:1998-02-06
Published:1998-02-06
Updated:2017-12-19
Summary:Screen savers in KDE beta 3 allows local users to overwrite arbitrary files via a symlink attack on the .kss.pid file.
CVSS v3 Severity:4.0 Medium (CCN CVSS v3.1 Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:2.1 Low (CVSS v2 Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
2.1 Low (CCN CVSS v2 Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-Other
Vulnerability Consequences:File Manipulation
References:Source: CCN
Type: BugTraq Mailing List, Fri, 6 Feb 1998 20:06:52 -0800
serious security hole in KDE Beta 3

Source: MITRE
Type: CNA
CVE-1999-1269

Source: CCN
Type: K Desktop Environment (KDE) Web site
K Desktop Environment Home

Source: CCN
Type: OSVDB ID: 12981
KDE Screen Savers .kss.pid Symlink Arbitrary File Overwrite

Source: BUGTRAQ
Type: Patch, Vendor Advisory
19980206 serious security hole in KDE Beta 3

Source: XF
Type: UNKNOWN
kde-kss-file-clobber(1641)

Source: XF
Type: UNKNOWN
kde-kss-file-clobber(1641)

Vulnerable Configuration:Configuration 1:
  • cpe:/o:kde:kde_beta_3:initial:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    BACK
    kde kde beta 3 initial