Vulnerability Name:

CVE-2000-0748 (CCN-5000)

Assigned:2000-07-27
Published:2000-07-27
Updated:2008-09-05
Summary:OpenLDAP 1.2.11 and earlier improperly installs the ud binary with group write permissions, which could allow any user in that group to replace the binary with a Trojan horse.
CVSS v3 Severity:5.9 Medium (CCN CVSS v3.1 Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:4.6 Medium (CVSS v2 Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
4.6 Medium (CCN CVSS v2 Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-Other
References:Source: BUGTRAQ
Type: Patch, Vendor Advisory
20000726 Group-writable executable in OpenLDAP

Source: MITRE
Type: CNA
CVE-2000-0748

Source: CCN
Type: Linux-Mandrake Security Update Advisory MDKSA-2000:024
openldap

Source: CCN
Type: OSVDB ID: 8030
OpenLDAP ud Group Write Permissions

Source: BID
Type: Patch, Vendor Advisory
1511

Source: CCN
Type: BID-1511
OpenLDAP ud Group Writable Vulnerability

Source: XF
Type: UNKNOWN
openldap-group-writable(5000)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:openldap:openldap:1.2.7:*:*:*:*:*:*:*
  • OR cpe:/a:openldap:openldap:1.2.8:*:*:*:*:*:*:*
  • OR cpe:/a:openldap:openldap:1.2.9:*:*:*:*:*:*:*
  • OR cpe:/a:openldap:openldap:1.2.10:*:*:*:*:*:*:*
  • OR cpe:/a:openldap:openldap:1.2.11:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:openldap:openldap:*:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    BACK
    openldap openldap 1.2.7
    openldap openldap 1.2.8
    openldap openldap 1.2.9
    openldap openldap 1.2.10
    openldap openldap 1.2.11
    openldap openldap *