Vulnerability Name:

CVE-2009-0887

Assigned:2009-02-25
Published:2009-02-25
Updated:2017-08-16
Summary:Integer signedness error in the _pam_StrTok function in libpam/pam_misc.c in Linux-PAM (aka pam) 1.0.3 and earlier, when a configuration file contains non-ASCII usernames, might allow remote attackers to cause a denial of service, and might allow remote authenticated users to obtain login access with a different user's non-ASCII username, via a login attempt.
CVSS v3 Severity:7.2 High (CCN CVSS v3 Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): High
Privileges Required (PR): High
User Interaction (UI): Required
Scope:Scope (S): Changed
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
CVSS v2 Severity:6.6 Medium (CVSS v2 Vector: AV:L/AC:M/Au:S/C:C/I:C/A:C)
5.7 Medium (Temporal CVSS v2 Vector: AV:L/AC:M/Au:S/C:C/I:C/A:C/E:H/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
5.9 Medium (CCN CVSS v2 Vector: AV:L/AC:H/Au:M/C:C/I:C/A:C)
5.1 Medium (CCN Temporal CVSS v2 Vector: AV:L/AC:H/Au:M/C:C/I:C/A:C/E:H/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Local
Access Complexity (AC): High
Athentication (Au): Multiple_Instances
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
Vulnerability Type:CWE-189
(ALLOWS_ADMIN_ACCESS)
References:Source: MLIST
Type: UNKNOWN
[oss-security] 20090305 CVE Request -- pam

Source: CONFIRM
Type: UNKNOWN
http://pam.cvs.sourceforge.net/viewvc/pam/Linux-PAM/libpam/pam_misc.c?r1=1.9&r2=1.10&view=patch

Source: CONFIRM
Type: UNKNOWN
http://pam.cvs.sourceforge.net/viewvc/pam/Linux-PAM/libpam/pam_misc.c?view=log

Source: MANDRIVA
Type: UNKNOWN
MDVSA-2009:077

Source: BID
Type: PATCH
34010

Source: XF
Type: UNKNOWN
linuxpam-pamstrtok-priv-escalation(49110)

Source: FEDORA
Type: UNKNOWN
FEDORA-2009-3204

Source: FEDORA
Type: UNKNOWN
FEDORA-2009-3231

Vulnerable Configuration:Configuration 1:
  • cpe:/a:kernel:linux-pam:1.0.3:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:1.0.2:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:1.0.1:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:1.0.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.9.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.8.1:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.8.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.7.1:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.7.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.6.3:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.6.2:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.6.1:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.6.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.5.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.4.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.3.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.2.1:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.2.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.1.0:*:*:*:*:*:*:*
  • OR cpe:/a:kernel:linux-pam:0.99.10.0:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20090887
    V
    CVE-2009-0887
    2018-08-15
    oval:org.mitre.oval:def:13730
    P
    USN-1140-2 -- pam regression
    2014-06-30
    oval:org.mitre.oval:def:13977
    P
    USN-1140-1 -- pam vulnerabilities
    2014-06-30
    BACK
    kernel linux-pam 1.0.3
    kernel linux-pam 1.0.2
    kernel linux-pam 1.0.1
    kernel linux-pam 1.0.0
    kernel linux-pam 0.99.9.0
    kernel linux-pam 0.99.8.1
    kernel linux-pam 0.99.8.0
    kernel linux-pam 0.99.7.1
    kernel linux-pam 0.99.7.0
    kernel linux-pam 0.99.6.3
    kernel linux-pam 0.99.6.2
    kernel linux-pam 0.99.6.1
    kernel linux-pam 0.99.6.0
    kernel linux-pam 0.99.5.0
    kernel linux-pam 0.99.4.0
    kernel linux-pam 0.99.3.0
    kernel linux-pam 0.99.2.1
    kernel linux-pam 0.99.2.0
    kernel linux-pam 0.99.1.0
    kernel linux-pam 0.99.10.0