Vulnerability Name:

CVE-2009-1036

Assigned:2009-03-18
Published:2009-03-18
Updated:2017-08-16
Summary:Cross-site request forgery (CSRF) vulnerability in the Plus 1 module before 6.x-2.6, a module for Drupal, allows remote attackers to cast votes for content via unspecified aspects of the URI.
CVSS v3 Severity:5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:6.8 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P)
5.9 Medium (Temporal CVSS v2 Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P/E:H/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
4.3 Medium (CCN CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N)
3.7 Low (CCN Temporal CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N/E:H/RL:OF/RC:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-352
References:Source: CONFIRM
Type: UNKNOWN
http://drupal.org/node/405672

Source: CONFIRM
Type: VENDOR_ADVISORY
http://drupal.org/node/406314

Source: BID
Type: UNKNOWN
34168

Source: XF
Type: UNKNOWN
plus1-unspecified-csrf(49310)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:drupal:plus1:6.x-1.0:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-1.1:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-1.2:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-1.3:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.0:beta2:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.0:beta3:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.0:beta4:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.0:beta5:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.2:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.1:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.0:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.3:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.4:*:*:*:*:*:*:*
  • OR cpe:/a:drupal:plus1:6.x-2.5:*:*:*:*:*:*:*
  • AND
  • cpe:/a:drupal:drupal:*:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    BACK
    drupal plus1 6.x-1.0
    drupal plus1 6.x-1.1
    drupal plus1 6.x-1.2
    drupal plus1 6.x-1.3
    drupal plus1 6.x-2.0 beta2
    drupal plus1 6.x-2.0 beta3
    drupal plus1 6.x-2.0 beta4
    drupal plus1 6.x-2.0 beta5
    drupal plus1 6.x-2.2
    drupal plus1 6.x-2.1
    drupal plus1 6.x-2.0
    drupal plus1 6.x-2.3
    drupal plus1 6.x-2.4
    drupal plus1 6.x-2.5
    drupal drupal *