Vulnerability Name:

CVE-2016-5240

Assigned:2016-05-01
Published:2016-05-01
Updated:2018-05-17
Summary:The DrawDashPolygon function in magick/render.c in GraphicsMagick before 1.3.24 and the SVG renderer in ImageMagick allow remote attackers to cause a denial of service (infinite loop) by converting a circularly defined SVG file.
CVSS v3 Severity:5.5 Medium (CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H)
4.8 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): High
4.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L)
3.8 Low (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:4.3 Medium (CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
4.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
4.3 Medium (REDHAT CVSS v2 Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
Vulnerability Type:CWE-20
References:Source: CONFIRM
Type: VENDOR_ADVISORY
http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset;node=ddc999ec896c

Source: DEBIAN
Type: UNKNOWN
DSA-3746

Source: CONFIRM
Type: VENDOR_ADVISORY
http://www.graphicsmagick.org/ChangeLog-2016.html

Source: MLIST
Type: VENDOR_ADVISORY
[oss-security] 20160501 CVE request: DoS in multiple versions of GraphicsMagick

Source: MLIST
Type: VENDOR_ADVISORY
[oss-security] 20160501 Re: CVE request: DoS in multiple versions of GraphicsMagick

Source: MLIST
Type: VENDOR_ADVISORY
[oss-security] 20160602 Re: CVE request: DoS in multiple versions of GraphicsMagick

Source: CONFIRM
Type: UNKNOWN
http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html

Source: BID
Type: VENDOR_ADVISORY
89348

Source: REDHAT
Type: UNKNOWN
RHSA-2016:1237

Source: XF
Type: UNKNOWN
imagemagick-cve20165240-dos(114231)

Vulnerable Configuration:Configuration 1:
  • cpe:/a:graphicsmagick:graphicsmagick:1.3.23:*:*:*:*:*:*:*

  • Configuration RedHat 1:
  • cpe:/o:redhat:enterprise_linux:6:*:*:*:*:*:*:*

  • Configuration RedHat 2:
  • cpe:/o:redhat:enterprise_linux:7:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:imagemagick:imagemagick:5.5.6.0_20030409:*:*:*:*:*:*:*
  • AND
  • cpe:/a:ibm:powerkvm:2.1:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_hpc_node_eus:7.2:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_server_aus:7.2:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_server_eus:7.2:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
  • OR cpe:/o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:20165240
    V
    CVE-2016-5240
    2018-08-15
    oval:com.ubuntu.precise:def:20165240000
    V
    CVE-2016-5240 on Ubuntu 12.04 LTS (precise) - medium.
    2017-02-27
    oval:com.ubuntu.trusty:def:20165240000
    V
    CVE-2016-5240 on Ubuntu 14.04 LTS (trusty) - medium.
    2017-02-27
    oval:com.ubuntu.artful:def:20165240000
    V
    CVE-2016-5240 on Ubuntu 17.10 (artful) - medium.
    2017-02-27
    oval:com.ubuntu.xenial:def:20165240000
    V
    CVE-2016-5240 on Ubuntu 16.04 LTS (xenial) - medium.
    2017-02-27
    oval:org.cisecurity:def:1656
    P
    DSA-3746-1 -- graphicsmagick -- security update
    2017-01-27
    oval:com.redhat.rhsa:def:20161237
    P
    RHSA-2016:1237: ImageMagick security update (Important)
    2016-07-18
    BACK
    graphicsmagick graphicsmagick 1.3.23
    imagemagick imagemagick 5.5.6.0_20030409
    ibm powerkvm 2.1
    redhat enterprise linux hpc node eus 7.2
    redhat enterprise linux server aus 7.2
    redhat enterprise linux server eus 7.2
    redhat enterprise linux desktop 6.0
    redhat enterprise linux server 6.0
    redhat enterprise linux workstation 6.0