Vulnerability Name:

CVE-2017-0367

Assigned:2016-11-29
Published:2018-04-06
Updated:2018-05-14
Summary:Mediawiki before 1.28.1 / 1.27.2 contains an unsafe use of temporary directory, where having LocalisationCache directory default to system tmp directory is insecure.
CVSS v3 Severity:8.8 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
7.7 High (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
7.3 High (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
6.4 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): Low
CVSS v2 Severity:6.5 Medium (CVSS v2 Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
7.5 High (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): Partial
Vulnerability Type:CWE-264
References:Source: XF
Type: UNKNOWN
mediawiki-cve20170367-code-exec(142471)

Source: MLIST
Type: VENDOR_ADVISORY
[mediawiki-announce] 20170406 Security Release: 1.28.1 / 1.27.2 / 1.23.16

Source: CONFIRM
Type: VENDOR_ADVISORY
https://phabricator.wikimedia.org/T161453

Source: CONFIRM
Type: VENDOR_ADVISORY
https://security-tracker.debian.org/tracker/CVE-2017-0367

Vulnerable Configuration:Configuration 1:
  • cpe:/a:mediawiki:mediawiki:1.27.0:*:*:*:*:*:*:*
  • OR cpe:/a:mediawiki:mediawiki:1.27.1:*:*:*:*:*:*:*
  • OR cpe:/a:mediawiki:mediawiki:1.28.0:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/o:debian:debian_linux:7.0:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:mediawiki:mediawiki:1.27.0:*:*:*:*:*:*:*
  • OR cpe:/a:mediawiki:mediawiki:1.23.14:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.trusty:def:20170367000
    V
    CVE-2017-0367 on Ubuntu 14.04 LTS (trusty) - untriaged.
    2018-04-13
    oval:com.ubuntu.artful:def:20170367000
    V
    CVE-2017-0367 on Ubuntu 17.10 (artful) - untriaged.
    2018-04-13
    oval:com.ubuntu.precise:def:20170367000
    V
    CVE-2017-0367 on Ubuntu 12.04 LTS (precise) - untriaged.
    2017-04-07
    BACK
    mediawiki mediawiki 1.27.0
    mediawiki mediawiki 1.27.1
    mediawiki mediawiki 1.28.0
    debian debian linux 7.0
    mediawiki mediawiki 1.27.0
    mediawiki mediawiki 1.23.14