Vulnerability Name:

CVE-2017-16820

Assigned:2017-11-14
Published:2017-11-14
Updated:2018-05-19
Summary:The csnmp_read_table function in snmp.c in the SNMP plugin in collectd before 5.6.3 is susceptible to a double free in a certain error case, which could lead to a crash (or potentially have other impact).
CVSS v3 Severity:9.8 Critical (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
8.5 High (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): High
Availibility (A): High
5.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
4.6 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Low
CVSS v2 Severity:10.0 High (CVSS v2 Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Complete
Integrity (I): Complete
Availibility (A): Complete
5.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): None
Availibility (A): Partial
Vulnerability Type:CWE-415
References:Source: REDHAT
Type: UNKNOWN
RHSA-2018:0252

Source: REDHAT
Type: UNKNOWN
RHSA-2018:0299

Source: REDHAT
Type: UNKNOWN
RHSA-2018:0560

Source: REDHAT
Type: UNKNOWN
RHSA-2018:1605

Source: CONFIRM
Type: VENDOR_ADVISORY
https://bugs.debian.org/881757

Source: XF
Type: UNKNOWN
collectd-cve201716820-dos(134974)

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/collectd/collectd/commit/d16c24542b2f96a194d43a73c2e5778822b9cb47

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/collectd/collectd/issues/2291

Source: CONFIRM
Type: VENDOR_ADVISORY
https://github.com/collectd/collectd/releases/tag/collectd-5.6.3

Source: GENTOO
Type: UNKNOWN
GLSA-201803-10

Vulnerable Configuration:Configuration 1:
  • cpe:/a:collectd:collectd:5.4.2:*:*:*:*:*:*:*
  • OR cpe:/a:collectd:collectd:5.5.1:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.trusty:def:201716820000
    V
    CVE-2017-16820 on Ubuntu 14.04 LTS (trusty) - untriaged.
    2017-11-14
    oval:com.ubuntu.xenial:def:201716820000
    V
    CVE-2017-16820 on Ubuntu 16.04 LTS (xenial) - untriaged.
    2017-11-14
    oval:com.ubuntu.artful:def:201716820000
    V
    CVE-2017-16820 on Ubuntu 17.10 (artful) - untriaged.
    2017-11-14
    BACK
    collectd collectd 5.4.2
    collectd collectd 5.5.1