Vulnerability Name:

CVE-2018-10860

Assigned:2018-06-29
Published:2018-06-29
Updated:2018-08-21
Summary:perl-archive-zip is vulnerable to a directory traversal in Archive::Zip. It was found that the Archive::Zip module did not properly sanitize paths while extracting zip files. An attacker able to provide a specially crafted archive for processing could use this flaw to write or overwrite arbitrary files in the context of the perl interpreter.
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N)
6.5 Medium (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): High
Availibility (A): None
4.3 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
3.8 Low (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:6.4 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): Partial
4.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-22
References:Source: BID
Type: VENDOR_ADVISORY
104580

Source: CONFIRM
Type: VENDOR_ADVISORY
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10860

Source: XF
Type: UNKNOWN
perlarchivezip-cve201810860-dir-traversal(145690)

Source: MLIST
Type: VENDOR_ADVISORY
[debian-lts-announce] 20180724 [SECURITY] [DLA 1440-1] libarchive-zip-perl security update

Source: UBUNTU
Type: VENDOR_ADVISORY
USN-3703-1

Source: UBUNTU
Type: VENDOR_ADVISORY
USN-3703-2

Vulnerable Configuration:Configuration 1:
  • cpe:/o:canonical:ubuntu_linux:12.04::~~esm~~~:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:*
  • OR cpe:/o:canonical:ubuntu_linux:18.04::~~lts~~~:*:*:*:*:*
  • OR cpe:/o:debian:debian_linux:8.0:*:*:*:*:*:*:*

  • Configuration 2:
  • cpe:/a:perl-archive-zip_project:perl-archive-zip:-:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:201810860
    V
    CVE-2018-10860
    2018-09-23
    oval:com.ubuntu.artful:def:201810860000
    V
    CVE-2018-10860 on Ubuntu 17.10 (artful) - medium.
    2018-06-29
    oval:com.ubuntu.bionic:def:201810860000
    V
    CVE-2018-10860 on Ubuntu 18.04 LTS (bionic) - medium.
    2018-06-29
    oval:com.ubuntu.trusty:def:201810860000
    V
    CVE-2018-10860 on Ubuntu 14.04 LTS (trusty) - medium.
    2018-06-29
    oval:com.ubuntu.xenial:def:201810860000
    V
    CVE-2018-10860 on Ubuntu 16.04 LTS (xenial) - medium.
    2018-06-29
    BACK
    canonical ubuntu linux 12.04
    canonical ubuntu linux 14.04
    canonical ubuntu linux 16.04
    canonical ubuntu linux 17.10
    canonical ubuntu linux 18.04
    debian debian linux 8.0
    perl-archive-zip_project perl-archive-zip -