Vulnerability Name:

CVE-2018-14526

Assigned:2018-08-08
Published:2018-08-08
Updated:2018-08-21
Summary:An issue was discovered in rsn_supp/wpa.c in wpa_supplicant 2.0 through 2.6. Under certain conditions, the integrity of EAPOL-Key messages is not checked, leading to a decryption oracle. An attacker within range of the Access Point and client can abuse the vulnerability to recover sensitive information.
CVSS v3 Severity:6.5 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
5.7 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Adjacent
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:6.1 Medium (CCN CVSS v2 Vector: AV:A/AC:L/Au:N/C:C/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Adjacent_Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Complete
Integrity (I): None
Availibility (A): None
References:Source: SECTRACK
Type: UNKNOWN
1041438

Source: XF
Type: UNKNOWN
wpasupplicant-cve201814526-info-disc(148095)

Source: MLIST
Type: UNKNOWN
[debian-lts-announce] 20180809 [SECURITY] [DLA 1462-1] wpa security update

Source: MISC
Type: UNKNOWN
https://papers.mathyvanhoef.com/woot2018.pdf

Source: FREEBSD
Type: UNKNOWN
FreeBSD-SA-18:11

Source: UBUNTU
Type: UNKNOWN
USN-3745-1

Source: MISC
Type: UNKNOWN
https://w1.fi/security/2018-1/unauthenticated-eapol-key-decryption.txt

Vulnerable Configuration:
Configuration CCN 1:
  • cpe:/a:w1.fi:wpa_supplicant:2.4:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.3:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.2:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.1:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.0:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.5:*:*:*:*:*:*:*
  • OR cpe:/a:w1.fi:wpa_supplicant:2.6:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:com.ubuntu.trusty:def:201814526000
    V
    CVE-2018-14526 on Ubuntu 14.04 LTS (trusty) - medium.
    2018-08-08
    oval:com.ubuntu.xenial:def:201814526000
    V
    CVE-2018-14526 on Ubuntu 16.04 LTS (xenial) - medium.
    2018-08-08
    BACK
    w1.fi wpa supplicant 2.4
    w1.fi wpa supplicant 2.3
    w1.fi wpa supplicant 2.2
    w1.fi wpa supplicant 2.1
    w1.fi wpa supplicant 2.0
    w1.fi wpa supplicant 2.5
    w1.fi wpa supplicant 2.6