Vulnerability Name:

CVE-2018-2424

Assigned:2017-12-15
Published:2017-12-15
Updated:2018-08-10
Summary:SAP UI5 did not validate user input before adding it to the DOM structure. This may lead to malicious user-provided JavaScript code being added to the DOM that could steal user information. Software components affected are: SAP Hana Database 1.00, 2.00; SAP UI5 1.00; SAP UI5 (Java) 7.30, 7.31, 7.40, 7,50; SAP UI 7.40, 7.50, 7.51, 7.52, and version 2.0 of SAP UI for SAP NetWeaver 7.00
CVSS v3 Severity:7.5 High (CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
7.2 High (Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): None
6.1 Medium (CCN CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
5.8 Medium (CCN Temporal CVSS v3 Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:H/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope:Scope (S): Changed
Impact Metrics:Confidentiality (C): Low
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:5.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
5.5 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-20
References:Source: BID
Type: VENDOR_ADVISORY
104459

Source: XF
Type: UNKNOWN
sap-cve20182424-xss(144729)

Source: MISC
Type: VENDOR_ADVISORY
https://launchpad.support.sap.com/#/notes/2538856

Source: CONFIRM
Type: VENDOR_ADVISORY
https://wiki.scn.sap.com/wiki/pages/viewpage.action?pageId=495289255

Vulnerable Configuration:Configuration 1:
  • cpe:/a:sap:hana_database:1.00:*:*:*:*:*:*:*
  • OR cpe:/a:sap:hana_database:2.00:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:2.0::~~~netweaver_7.0~~:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.40:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.50:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.51:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.52:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5:1.00:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5_java:7.30:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5_java:7.31:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5_java:7.40:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5_java:7.50:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:sap:netweaver:7.0:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.4:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.5:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.51:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui:7.52:*:*:*:*:*:*:*
  • OR cpe:/a:sap:ui5:1.00:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    BACK
    sap hana database 1.00
    sap hana database 2.00
    sap ui 2.0
    sap ui 7.40
    sap ui 7.50
    sap ui 7.51
    sap ui 7.52
    sap ui5 1.00
    sap ui5 java 7.30
    sap ui5 java 7.31
    sap ui5 java 7.40
    sap ui5 java 7.50
    sap netweaver 7.0
    sap ui 7.4
    sap ui 7.5
    sap ui 7.51
    sap ui 7.52
    sap ui5 1.00