Vulnerability Name:

CVE-2018-25010 (CCN-202255)

Assigned:2021-05-04
Published:2021-05-04
Updated:2021-07-23
Summary:A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ApplyFilter. The highest threat from this vulnerability is to data confidentiality and to the service availability.
CVSS v3 Severity:9.1 Critical (CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H)
7.9 High (Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): High
9.1 Critical (CCN CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H)
7.9 High (CCN Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): High
Integrity (I): None
Availibility (A): High
CVSS v2 Severity:6.4 Medium (CVSS v2 Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): None
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): Partial
9.4 High (CCN CVSS v2 Vector: AV:N/AC:L/Au:N/C:C/I:N/A:C)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): None
Impact Metrics:Confidentiality (C): Complete
Integrity (I): None
Availibility (A): Complete
Vulnerability Type:CWE-125
Vulnerability Consequences:Denial of Service
References:Source: MITRE
Type: CNA
CVE-2018-25010

Source: CCN
Type: Red Hat Bugzilla - Bug 1956918
(CVE-2018-25010) - CVE-2018-25010 libwebp: out-of-bounds read in ApplyFilter()

Source: MISC
Type: Issue Tracking, Patch, Third Party Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=1956918

Source: CCN
Type: libwebp Google GIT Repository
chromium / webm / libwebp / 1344a2e947c749d231141a295327e5b99b444d63

Source: XF
Type: UNKNOWN
libwebp-cve2018-25010-dos(202255)

Source: MLIST
Type: UNKNOWN
[debian-lts-announce] 20210605 [SECURITY] [DLA 2672-1] libwebp security update

Source: MLIST
Type: UNKNOWN
[debian-lts-announce] 20210606 [SECURITY] [DLA 2677-1] libwebp security update

Source: CONFIRM
Type: UNKNOWN
https://support.apple.com/kb/HT212601

Source: DEBIAN
Type: UNKNOWN
DSA-4930

Vulnerable Configuration:Configuration 1:
  • cpe:/a:webmproject:libwebp:*:*:*:*:*:*:*:* (Version < 1.0.1)

  • Configuration 2:
  • cpe:/o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*

  • Configuration CCN 1:
  • cpe:/a:webmproject:libwebp:1.0.0:*:*:*:*:*:*:*

  • * Denotes that component is vulnerable
    Oval Definitions
    Definition IDClassTitleLast Modified
    oval:org.opensuse.security:def:97033
    P
    Security update for libwebp (Critical)
    2021-06-04
    BACK
    webmproject libwebp *
    redhat enterprise linux 8.0
    webmproject libwebp 1.0.0