Vulnerability Name:

CVE-2021-21662 (CCN-203470)

Assigned:2021-06-10
Published:2021-06-10
Updated:2021-06-15
Summary:A missing permission check in Jenkins XebiaLabs XL Deploy Plugin 10.0.1 and earlier allows attackers with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.
CVSS v3 Severity:4.3 Medium (CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
3.8 Low (Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): None
Availibility (A): None
4.3 Medium (CCN CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
3.8 Low (CCN Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): Low
Integrity (I): None
Availibility (A): None
CVSS v2 Severity:4.0 Medium (CVSS v2 Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
4.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): Partial
Integrity (I): None
Availibility (A): None
Vulnerability Type:CWE-862
Vulnerability Consequences:Obtain Information
References:Source: MITRE
Type: CNA
CVE-2021-21662

Source: MLIST
Type: Mailing List, Third Party Advisory
[oss-security] 20210610 Multiple vulnerabilities in Jenkins plugins

Source: XF
Type: UNKNOWN
jenkins-cve202121662-info-disc(203470)

Source: CCN
Type: Jenkins Security Advisory 2021-06-10
This advisory announces vulnerabilities in the following Jenkins deliverables

Source: CONFIRM
Type: Vendor Advisory
https://www.jenkins.io/security/advisory/2021-06-10/#SECURITY-1981

Vulnerable Configuration:Configuration 1:
  • cpe:/a:jenkins:xebialabs_xl_deploy:*:*:*:*:*:jenkins:*:* (Version <= 10.0.1)

  • * Denotes that component is vulnerable
    BACK
    jenkins xebialabs xl deploy *