Vulnerability Name:

CVE-2021-39881 (CCN-210848)

Assigned:2021-10-01
Published:2021-10-01
Updated:2021-10-09
Summary:In all versions of GitLab CE/EE since version 7.7, the application may let a malicious user create an OAuth client application with arbitrary scope names which may allow the malicious user to trick unsuspecting users to authorize the malicious client application using the spoofed scope name and description.
CVSS v3 Severity:3.5 Low (CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N)
3.1 Low (Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
3.5 Low (CCN CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N)
3.1 Low (CCN Temporal CVSS v3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C)
Exploitability Metrics:Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): Required
Scope:Scope (S): Unchanged
Impact Metrics:Confidentiality (C): None
Integrity (I): Low
Availibility (A): None
CVSS v2 Severity:3.5 Low (CVSS v2 Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
4.0 Medium (CCN CVSS v2 Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N)
Exploitability Metrics:Access Vector (AV): Network
Access Complexity (AC): Low
Athentication (Au): Single_Instance
Impact Metrics:Confidentiality (C): None
Integrity (I): Partial
Availibility (A): None
Vulnerability Type:CWE-noinfo
Vulnerability Consequences:Bypass Security
References:Source: MITRE
Type: CNA
CVE-2021-39881

Source: XF
Type: UNKNOWN
gitlab-cve202139881-sec-bypass(210848)

Source: CCN
Type: GitLab Web site
CVE-2021-39881

Source: CONFIRM
Type: Vendor Advisory
https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39881.json

Source: MISC
Type: Broken Link
https://gitlab.com/gitlab-org/gitlab/-/issues/26695

Source: MISC
Type: Permissions Required, Third Party Advisory
https://hackerone.com/reports/494530

Vulnerable Configuration:Configuration 1:
  • cpe:/a:gitlab:gitlab:*:*:*:*:community:*:*:* (Version >= 7.7.0 and < 14.1.7)
  • OR cpe:/a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* (Version >= 7.7.0 and < 14.1.7)
  • OR cpe:/a:gitlab:gitlab:*:*:*:*:community:*:*:* (Version >= 14.2.0 and < 14.2.5)
  • OR cpe:/a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* (Version >= 14.2.0 and < 14.2.5)
  • OR cpe:/a:gitlab:gitlab:*:*:*:*:community:*:*:* (Version >= 14.3.0 and < 14.3.1)
  • OR cpe:/a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* (Version >= 14.3.0 and < 14.3.1)

  • * Denotes that component is vulnerable
    BACK
    gitlab gitlab *
    gitlab gitlab *
    gitlab gitlab *
    gitlab gitlab *
    gitlab gitlab *
    gitlab gitlab *